What version of blackberry desktop software manager do I need?

Question by Lloyd24: What version of blackberry desktop software manager do I need?
I have a curve 8830, and all I wish to do is transfer my contacts over. That is it

Best answer:

Answer by TalkingToToddlers.com
Just download version 5.0 which is the lastest, and pick the version WITHOUT media manager.

What do you think? Answer below!